#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(BEGIN.*?BOOL\:TRUE.*?END)"
Local $sString = "BEGIN" & @CRLF & _
"DESCRIPTION: 1234" & @CRLF & _
"BOOL:TRUE" & @CRLF & _
"END" & @CRLF & _
"BEGIN" & @CRLF & _
"DESCRIPTION: 4568" & @CRLF & _
"BOOL:TRUE" & @CRLF & _
"END" & @CRLF & _
"BEGIN" & @CRLF & _
"DESCRIPTION: 715310" & @CRLF & _
"BOOL:FALSE" & @CRLF & _
"END" & @CRLF & _
"BEGIN" & @CRLF & _
"DESCRIPTION: 12489453" & @CRLF & _
"BOOL:TRUE" & @CRLF & _
"END" & @CRLF & _
"BEGIN" & @CRLF & _
"DESCRIPTION: 41543" & @CRLF & _
"BOOL:FALSE" & @CRLF & _
"END"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")