import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(BEGIN.*?BOOL\\:TRUE.*?END)";
final String string = "BEGIN\n"
+ "DESCRIPTION: 1234\n"
+ "BOOL:TRUE\n"
+ "END\n"
+ "BEGIN\n"
+ "DESCRIPTION: 4568\n"
+ "BOOL:TRUE\n"
+ "END\n"
+ "BEGIN\n"
+ "DESCRIPTION: 715310\n"
+ "BOOL:FALSE\n"
+ "END\n"
+ "BEGIN\n"
+ "DESCRIPTION: 12489453\n"
+ "BOOL:TRUE\n"
+ "END\n"
+ "BEGIN\n"
+ "DESCRIPTION: 41543\n"
+ "BOOL:FALSE\n"
+ "END";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}