import re
regex = re.compile(r"^.*:(\d+):(root|(user\/.*))$", flags=re.IGNORECASE)
test_str = "arn:aws:iam::389617777922:root"
subst = "$1"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)