re = /^.*:(\d+):(root|(user\/.*))$/i
str = 'arn:aws:iam::389617777922:root'
subst = '$1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result