package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`(0[1-9]|1[012])[\/](0[1-9]|[12][0-9]|3[01])[\/](19|20)\d{2}`)
    var str = `02/29/1989`
    
    if len(re.FindStringIndex(str)) > 0 {
        fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
    }
}