re = /(0[1-9]|1[012])[\/](0[1-9]|[12][0-9]|3[01])[\/](19|20)\d{2}/
str = '02/29/1989'
# Print the match result
str.match(re) do |match|
puts match.to_s
end