re = /^(.*)(?=\/).*$/m
str = 'abye/>abye
abys/>abys
aced/>aced
aces/>aces
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result