import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+href\\s*=\\s*[\\\"\\']?(([^\\s\\\"\\']+)[\\\"\\'\\s]+rel=\"[^\"]*\")|\\s+href\\s*=\\s*[\\\"\\']?([^\\s\\\"\\']+)[\\\"\\'\\s]+";
final String string = "Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do \n"
+ "eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut \n"
+ "enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi \n"
+ "ut aliquip ex ea commodo consequat. <a href=\"http://example.com\" rel=\"nofollow\">Duis</a>\n"
+ "nirure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat\n"
+ "nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui\n"
+ "officia deserunt mollit anim id est laborum.\n"
+ "asd <a href=\"http://example.com\">Duis</a>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}