const regex = /\s+href\s*=\s*[\"\']?(([^\s\"\']+)[\"\'\s]+rel="[^"]*")|\s+href\s*=\s*[\"\']?([^\s\"\']+)[\"\'\s]+/imsg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+href\\s*=\\s*[\\"\\\']?(([^\\s\\"\\\']+)[\\"\\\'\\s]+rel="[^"]*")|\\s+href\\s*=\\s*[\\"\\\']?([^\\s\\"\\\']+)[\\"\\\'\\s]+', 'imsg')
const str = `Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do
eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut
enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi
ut aliquip ex ea commodo consequat. <a href="http://example.com" rel="nofollow">Duis</a>
nirure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat
nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui
officia deserunt mollit anim id est laborum.
asd <a href="http://example.com">Duis</a>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);