package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`_meta:\d+:`)
var str = `{
"webservers": {
"hosts": ["123.456.789", "123.987.963"],
"vars": {
"user": "Var Value"
}
},
"_meta:1:": {
"10.201.200.68": {
"host1": "value1",
"host3": "value3"
}
},
"apache": {
"hosts": ["123.456.789", "123.987.963"],
"vars": {
"gathering_facts": "no"
}
},
"_meta:2:": {
"10.201.200.54": {
"host1": "value1",
"ho3": "value3"
}
},
"ecs": {
"hosts": ["123.456.789", "123.987.963"],
"vars": {
"gathering_facts": "no"
}
},
"_meta:3:": {
"10.201.200.54": {
"host1": "value1",
"host3": "value3"
}
},
}`
var substitution = "_meta"
fmt.Println(re.ReplaceAllString(str, substitution))
}