import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "_meta:\\d+:";
final String string = "{\n"
+ " \"webservers\": {\n"
+ " \"hosts\": [\"123.456.789\", \"123.987.963\"],\n"
+ " \"vars\": {\n"
+ " \"user\": \"Var Value\"\n"
+ " }\n"
+ " },\n"
+ " \"_meta:1:\": {\n"
+ " \"10.201.200.68\": {\n"
+ " \"host1\": \"value1\",\n"
+ " \"host3\": \"value3\"\n"
+ " }\n"
+ " },\n"
+ " \"apache\": {\n"
+ " \"hosts\": [\"123.456.789\", \"123.987.963\"],\n"
+ " \"vars\": {\n"
+ " \"gathering_facts\": \"no\"\n"
+ " }\n"
+ " },\n"
+ " \"_meta:2:\": {\n"
+ " \"10.201.200.54\": {\n"
+ " \"host1\": \"value1\",\n"
+ " \"ho3\": \"value3\"\n"
+ " }\n"
+ " },\n"
+ " \"ecs\": {\n"
+ " \"hosts\": [\"123.456.789\", \"123.987.963\"],\n"
+ " \"vars\": {\n"
+ " \"gathering_facts\": \"no\"\n"
+ " }\n"
+ " },\n"
+ " \"_meta:3:\": {\n"
+ " \"10.201.200.54\": {\n"
+ " \"host1\": \"value1\",\n"
+ " \"host3\": \"value3\"\n"
+ " }\n"
+ " },\n"
+ "}";
final String subst = "_meta";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}