package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([12]\d)?(\d\d)[\.\/\-](0?[1-9]|1[012])[\.\/\-](0?[1-9]|[12]\d|3[01])\s([01]?[0-9]|2[0-3]):[0-5][0-9]$`)
var str = `2013.11.04 11:50`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}