using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"B,A|A,B|A|B";
string input = @"A
B
A,B
B,A";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}