$re = '/B,A|A,B|A|B/';
$str = 'A
B
A,B
B,A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);