# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?![-'])[\W\d_])+//g;t' <<< "co-ordinate11_
O'Brian"