const regex = new RegExp('((?![-\\'])[\\W\\d_])+', 'g')
const str = `co-ordinate11_
O'Brian`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);