use strict;
my $str = 'hgfhf ( $Q130A + $Q130B + $Q130C + $Q130D + $Q130E + $Q130F+ $Q130G + $Q130H + $Q130I + $Q130J + $Q130K + $Q130L + $Q130M ) != 100';
my $regex = qr/(?<![-+\/*(\s])((\s*\()?(?:(?:\s*\$Q\w+\s*|\d+\.?\d*\s*)[-+\/*])+(?:\s*\$Q\w+|\d+\.?\d*)\s*(?(2)\)))(\s*[=!><]+\s*)(\d+\.?\d*)/xp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}