import re
regex = re.compile(r"""
(?<![-+\/*(\s])((\s*\()?(?:(?:\s*\$Q\w+\s*|\d+\.?\d*\s*)[-+\/*])+(?:\s*\$Q\w+|\d+\.?\d*)\s*(?(2)\)))(\s*[=!><]+\s*)(\d+\.?\d*)
""", flags=re.VERBOSE)
test_str = "hgfhf ( $Q130A + $Q130B + $Q130C + $Q130D + $Q130E + $Q130F+ $Q130G + $Q130H + $Q130I + $Q130J + $Q130K + $Q130L + $Q130M ) != 100"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")