package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[pbrc:tl:[^]]*ad[^]]*]`)
var str = `[pbrc:tl:ad,xch]
[pbrc:tl:xch,ad,xyy]
[pbrc:tl:xch, xx, ad]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}