re = /\[pbrc:tl:[^]]*ad[^]]*]/
str = '[pbrc:tl:ad,xch]
[pbrc:tl:xch,ad,xyy]
[pbrc:tl:xch, xx, ad]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end