using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([0-9]+\.\s[\p{L}\s]+\.)|(\-\s[\p{L}\s]+)|(\*\s[\p{L}\s]+))$";
string input = @"* Line with asterisk
1. Numbered line.
2. Another numbered line.
- jfkldsjflksdajflkdsajflkasdjfd
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}