$re = '/^(([0-9]+\.\s[\p{L}\s]+\.)|(\-\s[\p{L}\s]+)|(\*\s[\p{L}\s]+))$/m';
$str = '* Line with asterisk
1. Numbered line.
2. Another numbered line.
- jfkldsjflksdajflkdsajflkasdjfd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);