using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\+([0-9A-Za-z-]+)(?:\.([0-9A-Za-z-]+))*$";
string input = @"+beta-bar.baz-bz.fd.zz";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}