$re = '/^\+([0-9A-Za-z-]+)(?:\.([0-9A-Za-z-]+))*$/';
$str = '+beta-bar.baz-bz.fd.zz';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);