using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(h.*e.*l.*l.*o.*)";
string input = @"Hey look at that lion!";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}