$re = '/(h.*e.*l.*l.*o.*)/i';
$str = 'Hey look at that lion!';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);