re = /\bthe\b((?:(?!\bthe\b).)*?)\bred dog\b/
str = 'If the quick brown dog jumps over the lazy red dog, then the crazy red dog will run past the lazy red dog.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end