$re = '/^[^.]+[0-9]+[ab](-[^.]+)?\b/m';
$str = 'test02a-d.test.example.net
test02b-d.test.example.net
test03a.test.example.net
test03b.test.example.net
test04-d.test.example.net
test05.test.example.net
test01.test90a-d.example.net
test1bw.test.example.net';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);