// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^.]+[0-9]+[ab](-[^.]+)?\b").unwrap();
let string = "test02a-d.test.example.net
test02b-d.test.example.net
test03a.test.example.net
test03b.test.example.net
test04-d.test.example.net
test05.test.example.net
test01.test90a-d.example.net
test1bw.test.example.net";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}