re = /'?(\w+(?:\s+\w+)*)'?\s+<?(\S+@[\w.-]+\.[a-zA-Z]{2,4}\b)/
str = 'Name Surname email@domain.com
\'Name Surname\' <email@domain.com>
\'Name Surname\' email@domain.com
Name Surname <email@domain.com>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end