const regex = /\d+\s*X\s*\K\d+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+\\s*X\\s*\\K\\d+', 'g')
const str = `6 X 8
6X8
600X800`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}