const regex = /^-+|-(?!.*?-)|(-){2,}/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^-+|-(?!.*?-)|(-){2,}', 'gi')
const str = `----welcome/asasdgrd/asd-------ast-yret-das-/456`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);