$re = '/^-+|-(?!.*?-)|(-){2,}/i';
$str = '----welcome/asasdgrd/asd-------ast-yret-das-/456';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;