package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\w .,-]+:[\w .,-]*[^\W_][\w .,-]*;`)
var str = `ONE:;TWO:,,d,-;THREE:fsdfsd;FOUR:43879293847;FIVE:dsa. dsa, 56;SIX: ;SEVEN:,,,;EIGHT:--;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}