const regex = /Available Times:\s*(?<available>.*?)\s+Other type of contact:\s*(?<contact>.*?)\s+Unavailable Times:\s*(?<unavailable>.*?)\s*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Available Times:\\s*(?<available>.*?)\\s+Other type of contact:\\s*(?<contact>.*?)\\s+Unavailable Times:\\s*(?<unavailable>.*?)\\s*$', '')
const str = ` Available Times: Monday Tuesday Wednesday 8-12 12-5 Other type of contact: SMS Unavailable Times: Thursday 8-12 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}