using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![^\w])[- ](?=\w)(*SKIP)(*FAIL)|\W+";
string input = @"-my-test of #$%^&*
accident-prone";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}