re = /(?<![^\w])[- ](?=\w)(*SKIP)(*FAIL)|\W+/
str = '-my-test of #$%^&*
accident-prone'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end