package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{%([^{}%]*(?:(?R)|)[^{}%]*)%}`)
var str = `{%email|{%user|{%test%}%}%} - {%phone|{%user.id%}%}
{%user.username|1%} {%user.id%}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}