$re = '/{%([^{}%]*(?:(?R)|)[^{}%]*)%}/';
$str = '{%email|{%user|{%test%}%}%} - {%phone|{%user.id%}%}
{%user.username|1%} {%user.id%}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);