#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\?)(\S*)"
Local $sString = "http://www.olafpleines.de/?dies-das-jenes" & @CRLF & _
"http://www.olafpleines.de/#viel?holter-die-polter" & @CRLF & _
"http://www.olafpleines.de/wer?wimmelbilderwimmellei" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")