const regex = /(\?)(\S*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\?)(\\S*)', 'gm')
const str = `http://www.olafpleines.de/?dies-das-jenes
http://www.olafpleines.de/#viel?holter-die-polter
http://www.olafpleines.de/wer?wimmelbilderwimmellei
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}