package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d*)(?:X|x)(?:\^(-?\d))?`)
var str = `15x^2 + 25X^-1 + `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}