$re = '/(\d*)(?:X|x)(?:\^(-?\d))?/';
$str = '15x^2 + 25X^-1 + ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);