re = /("+)(.*[\\"]?.*?)+?\1/
str = '"""hello"""
"hello\\"world"
"""hello world"""""
""hello\\""world \\"" dada""
"hello world \\\\"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end