use strict;
my $str = '<a class="button block left icon-phone" data-reveal="\\u06f0\\u06f9\\u06f3\\u06f6\\u06f5\\u06f6\\u06f8\\u06f1\\u06f6\\u06f2\\u06f1" href="#">';
my $regex = qr/data-reveal="(.+?)"/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}