re = /data-reveal="(.+?)"/
str = '<a class="button block left icon-phone" data-reveal="\\u06f0\\u06f9\\u06f3\\u06f6\\u06f5\\u06f6\\u06f8\\u06f1\\u06f6\\u06f2\\u06f1" href="#">'
# Print the match result
str.match(re) do |match|
puts match.to_s
end