#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https\:\/\/www\.bugaboo\.com\/.{2}\-.{2}\/(silla\-de\-coche|siege\-auto|autostoel|autokindersitz|car\-seat|babyskydd|seggiolino\-auto)\/"
Local $sString = "https://www.bugaboo.com/gb-en/car-seat/" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/es-es/silla-de-coche/" & @CRLF & _
"https://www.bugaboo.com/es-en/car-seat/" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/fr-fr/siege-auto/" & @CRLF & _
"https://www.bugaboo.com/fr-en/car-seat/" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/de-de/autokindersitz/" & @CRLF & _
"https://www.bugaboo.com/de-en/car-seat/" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/nl-nl/autostoel/" & @CRLF & _
"https://www.bugaboo.com/nl-en/car-seat/" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/sv-se/babyskydd/" & @CRLF & _
"https://www.bugaboo.com/se-en/car-seat/" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/it-it/seggiolino-auto/" & @CRLF & _
"https://www.bugaboo.com/it-en/car-seat/" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/dk-en/car-seat/" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/at-de/autokindersitz/" & @CRLF & _
"https://www.bugaboo.com/at-en/car-seat/" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/be-fr/siege-auto/" & @CRLF & _
"https://www.bugaboo.com/be-en/car-seat/" & @CRLF & _
"https://www.bugaboo.com/be-nl/autostoel/" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/ie-en/car-seat/" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/fi-en/car-seat/" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/hu-en/car-seat/" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/hr-en/car-seat/" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/si-en/car-seat/" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/lu-fr/siege-auto/" & @CRLF & _
"https://www.bugaboo.com/lu-en/car-seat/" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/cz-en/car-seat/" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/pt-en/car-seat/" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/sk-en/car-seat/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")