use strict;
my $str = 'https://www.bugaboo.com/gb-en/car-seat/
https://www.bugaboo.com/es-es/silla-de-coche/
https://www.bugaboo.com/es-en/car-seat/
https://www.bugaboo.com/fr-fr/siege-auto/
https://www.bugaboo.com/fr-en/car-seat/
https://www.bugaboo.com/de-de/autokindersitz/
https://www.bugaboo.com/de-en/car-seat/
https://www.bugaboo.com/nl-nl/autostoel/
https://www.bugaboo.com/nl-en/car-seat/
https://www.bugaboo.com/sv-se/babyskydd/
https://www.bugaboo.com/se-en/car-seat/
https://www.bugaboo.com/it-it/seggiolino-auto/
https://www.bugaboo.com/it-en/car-seat/
https://www.bugaboo.com/dk-en/car-seat/
https://www.bugaboo.com/at-de/autokindersitz/
https://www.bugaboo.com/at-en/car-seat/
https://www.bugaboo.com/be-fr/siege-auto/
https://www.bugaboo.com/be-en/car-seat/
https://www.bugaboo.com/be-nl/autostoel/
https://www.bugaboo.com/ie-en/car-seat/
https://www.bugaboo.com/fi-en/car-seat/
https://www.bugaboo.com/hu-en/car-seat/
https://www.bugaboo.com/hr-en/car-seat/
https://www.bugaboo.com/si-en/car-seat/
https://www.bugaboo.com/lu-fr/siege-auto/
https://www.bugaboo.com/lu-en/car-seat/
https://www.bugaboo.com/cz-en/car-seat/
https://www.bugaboo.com/pt-en/car-seat/
https://www.bugaboo.com/sk-en/car-seat/';
my $regex = qr/https\:\/\/www\.bugaboo\.com\/.{2}\-.{2}\/(silla\-de\-coche|siege\-auto|autostoel|autokindersitz|car\-seat|babyskydd|seggiolino\-auto)\//mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}