import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?J)https?://(?:[a-z0-9]+\\.)?livestream\\.com/\n"
+ "(?:\n"
+ " (?<id>accounts/[0-9]+/events/[0-9]+(?:/videos/[0-9]+)?)\n"
+ " |\n"
+ " [^\\s/]+/video\\?clipId=(?<id>[^\\s&]+)\n"
+ " |\n"
+ " (?<id>[^\\s/]+)\n"
+ ")";
final String string = "http://original.livestream.com/bethanychurchnh = bethanychurchnh\n\n"
+ "http://original.livestream.com/bethanychurchnh/video?clipId=flv_b54a694b-043c-4886-9f35-03c8008c23 = flv_b54a694b-043c-4886-9f35-03c8008c23\n\n"
+ "http://livestream.com/accounts/142499/events/3959775 = accounts/142499/events/3959775\n\n"
+ "http://livestream.com/accounts/142499/events/3959775/videos/83958146 = /accounts/142499/events/3959775/videos/83958146";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}