$re = '~(?J)https?://(?:[a-z0-9]+\.)?livestream\.com/
(?:
(?<id>accounts/[0-9]+/events/[0-9]+(?:/videos/[0-9]+)?)
|
[^\s/]+/video\?clipId=(?<id>[^\s&]+)
|
(?<id>[^\s/]+)
)~x';
$str = 'http://original.livestream.com/bethanychurchnh = bethanychurchnh
http://original.livestream.com/bethanychurchnh/video?clipId=flv_b54a694b-043c-4886-9f35-03c8008c23 = flv_b54a694b-043c-4886-9f35-03c8008c23
http://livestream.com/accounts/142499/events/3959775 = accounts/142499/events/3959775
http://livestream.com/accounts/142499/events/3959775/videos/83958146 = /accounts/142499/events/3959775/videos/83958146';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);